Degraded Service

Incident Report for Demio

Resolved

As of 3:53 PM PDT, all AWS services returned to normal operations and Demio is fully operational.
Posted Oct 20, 2025 - 20:51 EDT

Update

Service recovery across all AWS services continues to improve in the affected region
Posted Oct 20, 2025 - 16:08 EDT

Monitoring

Due to Amazon Web Service outage in N.Virginia, some our services are degraded. We are actively monitoring the system
Posted Oct 20, 2025 - 06:41 EDT
This incident affected: Webinar Room (Webinar Room API, Webinar Room WebSocket Server, Webinar Signaling API), Integrations (HubSpot APIs), and User Dashboard.