Degraded Services

Incident Report for Demio

Resolved

We have identified and resolved the issue affecting our systems. All services are fully operational and performing normally. We apologize for any disruption this may have caused and appreciate your patience.
Posted Mar 13, 2026 - 11:30 EDT

Investigating

We are currently investigating this issue.
Posted Mar 13, 2026 - 11:13 EDT
This incident affected: User Dashboard.